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1 Installation and Registration 

 

1.1 Prerequisite 

Before installing ElegantJ Beans, please ensure that your computer system and 

development environment are setup and working as per expectations.  Person 

evaluating ElegantJ Beans is expected to be able to write and execute simple 

JAVA applications. 

 

We provide free pre-purchase technical support to help you complete process of 

evaluation.  Mail to support@elegantJBeans.com for pre-purchase technical 

support. 

 

To be able to use ElegantJ Beans, your computer systems are required to have - 

 An IDE that supports Java 2 or higher, or  

 JDK 1.2.2 or higher 

 

Please note that evaluation version of ElegantJ Beans cannot be deployed for 

commercial, non-commercial or any other purpose in any possible way.  You may 

not build any software, applets or applications for distribution with evaluation 

version of ElegantJ Beans. 

 

This evaluation version is to be solely used by you to evaluate suitability of 

ElegantJ Beans for your needs.  For more details please go through License 

Agreement. 

 

1.2 Installation Procedure 

On extracting EJGauges.zip, following directories will be created - 

 Directory [jars] contains Jar file(s)  

 Directory [demos] contains demo application(s) with source code  

 Directory [docs] contains User Guide and Java API  

 

 

1.2.1 Installing on Windows 95/98 

To include ElegantJ Beanery in CLASSPATH, add following statement to your 

autoexec.bat file, 

 

set CLASSPATH= %CLASSPATH%; C:\ELEGANTJ\<ELEGANTJ_BENARY_HOME> 

\jars\<ELEGANTJ_BEAN>.jar; 

 

Restart Windows to make changes effective. 

 

 

1.2.2 Installing on Windows NT/2000 

Go to Control Panel and select System. You will find environment variables on 

Environment tab in Windows NT systems and on Advanced tab in Windows 2000 

systems. Find CLASSPATH environment variable or create it. 
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To include ElegantJ Beanary in the CLASSPATH, specify or add following value for 

variable - 

 

[EXISTING-CLASSES]; C:\<ELEGANTJ_BEANARY_HOME>\jars\ 

<ELEGANTJ_BEAN>.jar 

 

1.2.3 Installing on UNIX/Linux 

Before you begin using ElegantJ Beanary, you must manually configure 

CLASSPATH environment variable.  CLASSPATH must point to the location of 

classes and installation directory. For example, to set CLASSPATH for ElegantJ 

Beanary, 

 

setenv CLASSPATH:/usr/local/<ELEGANTJ_BEANARY_HOME>/jars/ 

<ELEGANTJ_BEAN>.jar; 

 

If you are using Bourne Shell, commands are, 

 

CLASSPATH= $CLASSPATH:.:/usr/local/<ELEGANTJ_BEANARY_HOME>/jars/ 

<ELEGANTJ_BEAN>.jar:export CLASSPATH 

 

1.3 Using with Different IDEs 

1.3.1 Borland JBuilder 

Follow the steps given below to create a new category and install Bean into 

Borland JBuilder. 

 

Create a New Category 

 Click menu Tools > Configure Palette.  It opens Palette Properties 

dialog box 

 Click Add button.  It opens Add Page dialog box.  Specify name (for 

example ElegantJ) and click OK.  New category gets created. 

 

Create New Library and Install/Import Bean 

 On Palette Properties dialog box, click Pages tab.  Select newly created 

page (for example ElegantJ). 
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 Click button Select Library.  Select a Different Library dialog box 

opens. 
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 Click New button on Select a Different Library dialog box.  New 

Library Wizard dialog box opens.  

 Specify name for library and click Add button.  Select One or More 

Directory dialog box opens. 

 

 
 

 Select directory where jar files are located, or select jar file to be 

imported.  Click OK.  Dialog box gets closed and New Library Wizard 

dialog box appears in front. 
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 Click OK on New Library Wizard.  It opens Select a Different Library 

dialog box. 

 Confirm that newly created library is selected.  Click OK.  It opens Add 

Components under Palette Properties. 

 Click Add from Selected Libraries button.  It opens Results dialog box, 

click OK. 

 Results dialog box disappears.  Click OK on Palette Properties dialog 

box.  

 Beans are ready to use. 

 

 

1.3.2 IBM Visual Age 

Follow the steps given below to create an application in VisualAge and import 

ElegantJ Bean into the application. 

 

Create an application 

Open IBM VisualAge to work as Administrator. 

 Click menu File>QuickStart.  It opens Quick Start dialog box. 

 

 
 

 On Left pane, click Basic.  On right pane, click Create Application.  Click 

OK.  It opens Create Application step of SmartGuide dialog box. 

 In Project entry box, specify Project (for example, ElegantJDemoApp).  

In Package entry box, specify package name (for example, ejdemoapp).  

In Class entry box, specify Class name (for example ElegantJDemoApp). 

 Select "Create Swing based application" if you are working with JFC.  

Select "Create AWT based application" if you are working with AWT. 
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 Click Finish button.  Application will be created and it will open new 

window for ElegantJDemoApp. 
 

To Import Beans in the Application 

 In ElegantJDemoApp (the example used here) application window, click 

menu File > Import... .  Import dialog of SmartGuide opens. 
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 Choose Jar file as import source. Click Next to proceed.  

 From Jar/Zip file dialog box, browse location and get jar file in Filename 

entry box.  On the same dialog box, confirm that .class and resources 

options are selected under What type of files do you want to import? 
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 Click Finish button.  It opens Modify Palette dialog box. 

 To create a new category, click New Category button.  Specify name of 

category (for example, ElegantJ).  Confirm that newly created category is 

highlighted, select bean you want to import from Available Beans area of 

the dialog box.  

 Click Add To Category button to complete the process.  Click OK. 
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 Beans are ready to use. 

 

Note: Microsoft, IBM, VisualJ, PowerJ, JBuilder, Borland, Forte, NetBeans, 

VisualAge, JDeveloper, SUN Microsystems, ORACLE, JAVA, WINDOWS, 

Internet Explorer, Netscape, Opera, Adobe, PDF are not intended to indicate 

any specific relation to Elegant MicroWeb Technologies Pvt. Ltd. or ElelgantJ 

or ElegantJ Beans.  The corporation who own these trademarks are not 

related or connected with Elegant MicroWeb Technologies Pvt Ltd or 

ElegantJ or ElegantJ Beans in any way.  The respective corporations own 

these trademarks. They have only been mentioned in this and other 

documentations to demonstrate or support the use of these products with 

ElegantJ Beans or as related information. ALL TRADEMARKS ARE DULY 

ACKNOWLEDGED. 

 

 

1.3.3 Forte4Java 

Follow the steps given below to create a new category for ElegantJ Beans and add 

Beans to Sun Forte4Java. 

 

Create a new Palette Category 

 To create a new Palette Category, right-click the mouse on Palette 

Categories tab.  A context menu opens.    

 Click menu option Create New Category.  It opens New Palette Category 

dialog box.  Specify Category name, for example - ElegantJ.  Click OK.  

New category is created. 

 

 
 

To import Beans 

 Click menu Tools > Install New JavaBean... .  It opens Install 

JavaBean dialog Box.  

 Browse and select the jar file that you want to install/import. 

 Click OK.  It auto-detects beans available in Jar file and displays their 

names in Select JavaBean dialog box. 

 Select the bean that you want to install.  

 Click OK.  It opens Palette Category dialog box, which lists newly added 

Category. 
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To add selected Beans into newly created category 

 From Palette Category dialog box, select newly created category 

(example here, ElegantJ) 

 Click OK.  Beans will get installed under this category. 

 

 
 

 Beans are ready to use. 
 

Note: Microsoft, IBM, VisualJ, PowerJ, JBuilder, Borland, Forte, NetBeans, 

VisualAge, JDeveloper, SUN Microsystems, ORACLE, JAVA, WINDOWS, 

Internet Explorer, Netscape, Opera, Adobe, PDF are not intended to indicate 

any specific relation to Elegant MicroWeb Technologies Pvt. Ltd. or ElelgantJ 

or ElegantJ Beans.  The corporation who own these trademarks are not 

related or connected with Elegant MicroWeb Technologies Pvt Ltd or 

ElegantJ or ElegantJ Beans in any way.  The respective corporations own 
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these trademarks. They have only been mentioned in this and other 

documentations to demonstrate or support the use of these products with 

ElegantJ Beans or as related information. ALL TRADEMARKS ARE DULY 

ACKNOWLEDGED. 

 

1.3.4 Oracle JDeveloper 

Follow the steps given below to import ElegantJ Beans in Oracle JDeveloper. 

 

To Import beans into a project 

 Click menu Project > Project Settings.  It opens Project Settings dialog 

box. 

 

 
 

 Click Libraries entry appearing on the pane on left side. 

 Click New button.  It opens New Library dialog box. 
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 In Library Name entry box, specify Library name. In Location entry box, 

specify location where you want the library to be located.  In Class Path 

entry box, specify path of jar file of Bean. Browse the location by clicking 

Edit... button if required. 

 Click OK.  The library you selected appears in Available Libraries list of 

Project Properties dialog box. 

 Select the library you want and click > button to add it to Selected 

Libraries list. 

 Click menu Tools > Configure Component Palette.  It opens 

Configure Component Palette dialog box.  

 To create a new palette page, click New Page... button.  It opens New 

Palette Page dialog box.  Specify Page Name and Page Type.  Click 

OK.  A new page with specified name will be created. 

 

 
 

To add component to page 

 On Configure Component dialog box, from Pages list, select the page 

and click Add Component button.  It opens Add JavaBeans dialog box 

with available libraries. 

 Select a library from Library combo box. 

 Browse the hierarchy and select a component.  It displays preview of icon 

for selected component.  Click OK.  It shows Palette Confirmation dialog 

box.  

 Click Yes on Palette Confirmation dialog box to complete the process. 

 Beans are ready to use. 

 

Note: Microsoft, IBM, VisualJ, PowerJ, JBuilder, Borland, Forte, NetBeans, 

VisualAge, JDeveloper, SUN Microsystems, ORACLE, JAVA, WINDOWS, 

Internet Explorer, Netscape, Opera, Adobe, PDF are not intended to indicate 

any specific relation to Elegant MicroWeb Technologies Pvt. Ltd. or ElelgantJ 

or ElegantJ Beans.  The corporation who own these trademarks are not 

related or connected with Elegant MicroWeb Technologies Pvt Ltd or 

ElegantJ or ElegantJ Beans in any way.  The respective corporations own 

these trademarks. They have only been mentioned in this and other 
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documentations to demonstrate or support the use of these products with 

ElegantJ Beans or as related information. ALL TRADEMARKS ARE DULY 

ACKNOWLEDGED. 

 

 

1.4 Getting Registered 

1.4.1 How to Purchase 

You can purchase a license from our web site www.elegantJBeans.com 

You can also contact our sales team sales@elegantJBeans.com 

 

On purchasing a license, you will receive a mail having your license key. 

 

1.4.2 Using with Graphical User Interface of IDE 

While designing an application or an applet graphically in an Integrated 

Development Environment, you will find a property named LicenseKey along with 

other properties of the bean.  Specify key (serial number) in LicenseKey property. 

 

 
 

Note: Instead of typing the license key, we suggest you to copy the license 

key from mail and paste it at required place.  Make sure that the selection 

does not have any leading or trailing spaces. 

 

1.4.3 Using directly with source code 

When you use the Bean within code, you need to set the key by providing value 

in setLicenseKey Method. 

 

Note: Instead of typing the license key, we suggest you to copy the license 

key from mail and paste it at required place.  Make sure that the selection 

does not have leading or trailing spaces. 

 

ClassName object = new ClassName(); 

object.setLicenseKey("LICENSE_KEY"); 

 

Example 

 

AWTTree awtTree = new AWTTree(); 

awtTree.setLicenseKey("LICENSE_KEY"); 
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2 Product and Support Information 

 

Product & Support Information: 

 You can find more information about ElegantJ Indicator & Gauges and it's 

features on www.ElegantJCharts.com. 

 If you looking for further support apart from this documentation, then you 

can purchase our support package from the website. 

 Forward your sales related mail to sales@ElegantJCharts.com. 

 

Feedback and Suggestions: 

 We will be pleased to get your feedback as well as suggestions about our 

products. 

 Forward any feedback or suggestions related mails to 

support@ElegantJCharts.com. 

 

http://www.elegantjcharts.com/
mailto:sales@ElegantJCharts.com
mailto:support@ElegantJCharts.com

